SharePoint foundation 2013 Offline Installation

I was trying today to install SharePoint foundation 2013. The Prerequisites Installer could not download the dependencies, i did not search why and i wanted to perform an offline installation.

Solution :

  1. Download all the prerequisites.
  2. Extract the sharepoint installer : sharepoint.exe /extract:”C:\SharePoint2013\prerequisiteinstallerfiles”
  3. Copy the downloaded prerequisites to “C:\SharePoint2013\”
  4. Run again the prerequisiteinstaller.

 

Microsoft .NET Framework 4.5

(Full Stand alone package)

http://go.microsoft.com/fwlink/?LinkId=225702
Windows Management Framework 3.0 http://www.microsoft.com/en-us/download/details.aspx?id=34595
Microsoft SQL Server 2008 R2 SP1 Native Client http://www.microsoft.com/en-us/download/details.aspx?id=26728
Windows Identity Foundation (KB974405) http://go.microsoft.com/fwlink/p/?LinkID=226830
Windows Identity Extensions http://go.microsoft.com/fwlink/?LinkID=252368
Microsoft Sync Framework Runtime v1.0 SP1 (x64) http://go.microsoft.com/fwlink/p/?LinkID=224449
Windows Server AppFabric http://go.microsoft.com/fwlink/?LinkId=235496

 

 

Microsoft Information Protection and Control Client http://go.microsoft.com/fwlink/p/?LinkID=219568
Microsoft WCF Data Services 5.0 http://www.microsoft.com/en-us/download/details.aspx?id=29306
Cumulative Update Package 1 for Microsoft AppFabric 1.1 for Windows Server (KB2671763  

http://www.microsoft.com/en-us/download/details.aspx?id=29241

 

 

Advertisements

SharePoint 2013 Foundation Installation : This product requires Microsoft .Net Framework 4.5

I was trying to install SharePoint 2013 Foundaiton on a Windows Server 2012 R2. Microsoft says that only a SP1 pack is installable on a Windows Server 2012 R2.

I run the prerequisites and installed the dependencies offline including .Net Framework 4.5.

Problem :

When i start the installation i get this error :

This product requires Microsoft .Net Framework 4.5

It was very weird because when i try to add the .Net Framework 4.5 Feature, The Server Manager shows that it is already installed.

 

 

 

 

 

 

 

 

 

 

 

 

Solution :

My first thought was : maybe i am missing some updates. I checked The Microsoft Updates center and everything was up-to-date… and that is the Problem, Sharepoint 2013 is since 2013, and having a very up-to-date Server could cause issues.

I checked the .Net Framework Version :

 Set-Location 'HKLM:\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Client'
 Get-ItemProperty -Path . | Select-Object Version

And i found that the 4.7 version was installed. To Uninstall it i had to uninstall the Update KB3186539 .

Open the Windows Update Center and search for this KB.

Be carefull : The KB depends on which version of .Net framework you found, search for “The .NET Framework XX.XX offline installer for Windows” and you will find which KB is related to it and just uninstall it.