SharePoint 2013 Foundation Installation : This product requires Microsoft .Net Framework 4.5

I was trying to install SharePoint 2013 Foundaiton on a Windows Server 2012 R2. Microsoft says that only a SP1 pack is installable on a Windows Server 2012 R2.

I run the prerequisites and installed the dependencies offline including .Net Framework 4.5.

Problem :

When i start the installation i get this error :

This product requires Microsoft .Net Framework 4.5

It was very weird because when i try to add the .Net Framework 4.5 Feature, The Server Manager shows that it is already installed.

 

 

 

 

 

 

 

 

 

 

 

 

Solution :

My first thought was : maybe i am missing some updates. I checked The Microsoft Updates center and everything was up-to-date… and that is the Problem, Sharepoint 2013 is since 2013, and having a very up-to-date Server could cause issues.

I checked the .Net Framework Version :

 Set-Location 'HKLM:\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Client'
 Get-ItemProperty -Path . | Select-Object Version

And i found that the 4.7 version was installed. To Uninstall it i had to uninstall the Update KB3186539 .

Open the Windows Update Center and search for this KB.

Be carefull : The KB depends on which version of .Net framework you found, search for “The .NET Framework XX.XX offline installer for Windows” and you will find which KB is related to it and just uninstall it.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s