SharePoint Search crawler : Object was not found sps3

Today i ran into a problem while trying to crawl/index from the User Profile :

The start address sps3://…. cannot be crawled

The object was not found

sps3 is the protocol to crawl User Profile informations on SharePoint.

Possible reasons :

  • You are having a multi farm architecture and configured AAM : solution is to change the URL after sps3 to use the Url you configured on your DNS and AAM
  • You are using HTTPS : change sps3:// with sps3s://

 

If it helped you, please leave a comment.

Advertisements

SharePoint : Connection with Office Web Apps via SSL/HTTPS : new-spwopibinding the server did not respond

Office Web Apps, which is now Office Online Server, allows to display/edit Office documents(Word, Powerpoint, Excel…etc) on a Web Browser, which is advantageous when working with SharePoint, thus Users don’t have to switch from a Browser to Office App to see or to edit a document.

Today i faced a Problem that made me crazy while connecting SharePoint and Office Webapps(Office Server Online).

When i run the command

New-SPWOPIbinding -ServerName srv-apps

I got the error : “The Server does not respond, trying again”, if i add the parameter -AllowHttp it works though… but here i am trying to implement a HTTPS connection.

So here the steps that i followed to resolve the problem.

Office Server Online :

Before starting the Setup.exe from the Installation DVD, you should install those Windows-Feature prerequisites :

   Add-WindowsFeature Web-Server,Web-Mgmt-Tools,Web-Mgmt-Console,
     Web-WebServer,Web-Common-Http,Web-Default-Doc,Web-Static-Content,Web-Performance,
     Web-Stat-Compression,Web-Dyn-Compression,Web-Security,Web-Filtering,Web-Windows-Auth,
     Web-App-Dev,Web-Net-Ext45,Web-Asp-Net45,Web-ISAPI-Ext,Web-ISAPI-Filter,Web-Includes,
     NET-Framework-Features,NET-Framework-45-Features,NET-Framework-Core,NET-Framework-45-Core,NET-HTTP-Activation,NET-Non-HTTP-Activ,
     NET-WCF-HTTP-Activation45,Windows-Identity-Foundation,Server-Media-Foundation

Now you are ready to start the Setup.exe.

After the installation let’s configure our Office Server Online Farm :

New-OfficeWebAppsFarm -ExternalUrl “https://webapps.sharepoint.yourdomain.com” -InternalURL “https://webapps.sharepoint.yourdomain.com” -EditingEnabled -CertificateName “SharePoint Certificate”

3 important things :

  • The Url i chose was a subdomain of my sharepoint domain for the only reason that i wanted to use one single Certificate for both of them
  • ExternalURL and InternalURL are also the same : it was unfortunately the only solution i found to bypass the LoadBalancer problem
  • Of course don’t forget the DNS entry webapps.sharepoint.yourdomain.com <-> Officer Server Online

Last step on the Office Online Server is to load the certificate on IIS :

 

SharePoint :

Now lets move on to SharePoint and it is quite easy, we first need to set a Property on the Farm’s Propertybag.

$farm = Get-SPFarm

$farm.Properties.Add(“WopiLegacySoapSupport”, “https://webapps.sharepoint.yourdomain.com/x/_vti_bin/ExcelServiceInternal.asmx&#8221;)

$farm.Update()

Another step is to allow OAuth over HTTP

$config = (Get-SPSecurityTokenServiceConfig)

$config.AllowOaAuthOverHttp = $true

$config.Update()

Next Step is to create the Binding

New-SPWOPIBinding -ServerName webapps.sharepoint.yourdomain.com

Here it is important to give the FQDN that you used as internal URL, if you just use the server name you will get the error mentioned up.

and last but not Least set the Zone, you can use “internal-https” if your farm is only internally accessible, otherwise you should use “external-https”

Set-SPWOPIZone -zone “external-https”

 

Finally :

To test if it worked navigate to a SharePoint SiteCollection and you will notice that when you click on “+ new” inside a Library you will now get the Office Templates, instead of the Upload Pop-Up.

You will also be able to see the Document Preview and of course open the document in the Browser instead of getting it downloaded.

SharePoint – AAM : Alternate Access Mapping with HTTPS/SSL

When you install a new SharePoint Farm the default URL will be the name of the server, which is usually not beautiful(http://sp-srv, http://sharepoint…etc).

Today we will se how to configure the AAM with HTTPS.

Certificate :

I will not explain how to get the certificate in this article, you can also use a self signed one.

Once you have the .ptx Certificate you double click on it(on the SharePoint Frontend Server) and follow the Wizard to install it on the computer.

IIS :

We need to extend the Bindings of the SharePoint Website on IIS.

  1. Select the SharePoint Website
  2. Click on Bindings
  3. Add a new binding with 443 port and https
  4. Select the Certificate(the Certificate should appear on the list after being installed, if not you can import it via IIS).

 

SharePoint :

It is not enough to install the certificate on the server, this one should be also uploaded to SharePoint.

Open the Central Administration and then click on “Manage Trust” under “Security” and then click on new :

If you get an error that SharePoint doesn’t support certificates with password, don’t panic, you can export a copy of the certificate, that doesn’t require passwords.

  1. open “Manage Computer Certificates” on the Server(where you installed your certificate).
  2. Navigate to “SharePoint”
  3. right click on the Certificate(not the root!)
  4. Under “All Tasks” click on Export
  5. Click on “Next”
  6. Choose “do not export the private key”
  7. Choose the first format “DER encoded binary X.509”
  8. Choose a location and voila

Alternate Access Mapping :

Last but not least we should tell SharePoint that he has now to respond to requests from the adjusted URL.

Central Administration -> Application Management -> Configure alternate access mappings -> Edit Public URLs

  1. Select the correct Webapplication
  2. On the zone “Internet” add the full url with https
  3. Save

Your AAM settings should look like this now

 

 

SharePoint 2013 Foundation Installation : This product requires Microsoft .Net Framework 4.5

I was trying to install SharePoint 2013 Foundaiton on a Windows Server 2012 R2. Microsoft says that only a SP1 pack is installable on a Windows Server 2012 R2.

I run the prerequisites and installed the dependencies offline including .Net Framework 4.5.

Problem :

When i start the installation i get this error :

This product requires Microsoft .Net Framework 4.5

It was very weird because when i try to add the .Net Framework 4.5 Feature, The Server Manager shows that it is already installed.

 

 

 

 

 

 

 

 

 

 

 

 

Solution :

My first thought was : maybe i am missing some updates. I checked The Microsoft Updates center and everything was up-to-date… and that is the Problem, Sharepoint 2013 is since 2013, and having a very up-to-date Server could cause issues.

I checked the .Net Framework Version :

 Set-Location 'HKLM:\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Client'
 Get-ItemProperty -Path . | Select-Object Version

And i found that the 4.7 version was installed. To Uninstall it i had to uninstall the Update KB3186539 .

Open the Windows Update Center and search for this KB.

Be carefull : The KB depends on which version of .Net framework you found, search for “The .NET Framework XX.XX offline installer for Windows” and you will find which KB is related to it and just uninstall it.